splitToPathsBetweenFlagBreaks MethodStatic
Create paths assembled from many curves.
- Assemble consecutive curves NOT separated by either end flags or gaps into paths.
- Return simplest form -- single primitive, single path, or bag of curves.
splitToPathsBetweenFlagBreaks(source: undefined | CurvePrimitive | CurveCollection, makeClones: boolean): undefined | CurvePrimitive | Path | Loop | BagOfCurves
Parameter | Type | Description |
---|---|---|
source | undefined | CurvePrimitive | CurveCollection | |
makeClones | boolean |
Returns - undefined | CurvePrimitive | Path | Loop | BagOfCurves
Defined in
- curve/RegionOps.ts Line 427
Last Updated: 30 November, 2023