splitPathsByRegionInOnOutXY MethodStatic
- Find intersections of
curvesToCut
with boundaries ofregion
. - Break
curvesToCut
into parts inside, outside, and coincident. - Return all fragments, split among
insideParts
,outsideParts
, andcoincidentParts
in the output object.
splitPathsByRegionInOnOutXY(curvesToCut: undefined | CurvePrimitive | CurveCollection, region: AnyRegion): { coincidentParts: AnyCurve[], insideParts: AnyCurve[], outsideParts: AnyCurve[] }
Parameter | Type | Description |
---|---|---|
curvesToCut | undefined | CurvePrimitive | CurveCollection | |
region | AnyRegion |
Returns - { coincidentParts: AnyCurve[], insideParts: AnyCurve[], outsideParts: AnyCurve[] }
Defined in
- curve/RegionOps.ts Line 466
Last Updated: 30 November, 2023