sortOuterAndHoleLoopsXY MethodStatic
If reverse loops as necessary to make them all have CCW orientation for given outward normal.
- Return an array of arrays which capture the input pointers.
- In each first level array:
- The first loop is an outer loop.
- all subsequent loops are holes
- The outer loop is CCW
- The holes are CW.
- Call PolygonOps.sortOuterAndHoleLoopsXY to have the result returned as an array of arrays of polygons.
sortOuterAndHoleLoopsXY(loops: IndexedXYZCollection | Loop[]): AnyRegion
Parameter | Type | Description |
---|---|---|
loops | IndexedXYZCollection | Loop[] | multiple loops to sort and reverse. |
Returns - AnyRegion
Defined in
- curve/RegionOps.ts Line 575
Last Updated: 30 November, 2023