polygonBooleanXYToPolyface MethodStatic
return a polyface whose facets area a boolean operation between the input regions.
- Each of the two inputs is an array of multiple loops or parity regions.
- Within each of these input arrays, the various entries (loop or set of loops) are interpreted as a union.
- In each "array of loops and parity regions", each entry inputA[i] or inputB[i] is one of:
- A simple loop, e.g. array of Point3d.
- Several simple loops, each of which is an array of Point3d.
polygonBooleanXYToPolyface(inputA: MultiLineStringDataVariant[], operation: RegionBinaryOpType, inputB: MultiLineStringDataVariant[], triangulate: boolean = false): undefined | Polyface
Parameter | Type | Description |
---|---|---|
inputA | MultiLineStringDataVariant[] | |
operation | RegionBinaryOpType | |
inputB | MultiLineStringDataVariant[] | |
triangulate | boolean |
Returns - undefined | Polyface
Defined in
- curve/RegionOps.ts Line 292
Last Updated: 30 November, 2023