createLoopPathOrBagOfCurves MethodStatic
Create curve collection of subtype determined by gaps between the input curves.
- If (a) wrap is requested and (b) all curves connect head-to-tail (including wraparound), assemble as a
loop
. - If all curves connect head-to-tail except for closure, return a
Path
. - If there are internal gaps, return a
BagOfCurves
- If input array has zero length, return undefined.
createLoopPathOrBagOfCurves(curves: CurvePrimitive[], wrap: boolean = true, consolidateAdjacentPrimitives: boolean = false): undefined | CurveCollection
Parameter | Type | Description |
---|---|---|
curves | CurvePrimitive[] | |
wrap | boolean | |
consolidateAdjacentPrimitives | boolean |
Returns - undefined | CurveCollection
Defined in
- curve/RegionOps.ts Line 379
Last Updated: 30 November, 2023