constructPolygonWireXYOffset MethodStatic
Construct a wire (not area!!) that is offset from given polyline or polygon.
- This is a simple wire offset, not an area.
- The construction algorithm attempts to eliminate some self-intersections within the offsets, but does not guarantee a simple area offset.
- The construction algorithm is subject to being changed, resulting in different (hopefully better) self-intersection behavior on the future.
constructPolygonWireXYOffset(points: Point3d[], wrap: boolean, offsetDistance: number): undefined | CurveCollection
Parameter | Type | Description |
---|---|---|
points | Point3d[] | a single loop or path |
wrap | boolean | true to include wraparound |
offsetDistance | number | distance of offset from wire. Positive is left. |
Returns - undefined | CurveCollection
Defined in
- curve/RegionOps.ts Line 342
Last Updated: 30 November, 2023