constructCurveXYOffset MethodStatic
Construct curves that are offset from a Path or Loop as viewed in xy-plane (ignoring z).
- The construction will remove "some" local effects of features smaller than the offset distance, but will not detect self intersection among widely separated edges.
- If offsetDistance is given as a number, default OffsetOptions are applied.
- When the offset needs to do an "outside" turn, the first applicable construction is applied:
- If the turn is larger than
options.minArcDegrees
, a circular arc is constructed. - If the turn is less than or equal to
options.maxChamferTurnDegrees
, extend curves along tangent to single intersection point. - If the turn is larger than
options.maxChamferDegrees
, the turn is constructed as a sequence of straight lines that are:- outside the arc
- have uniform turn angle less than
options.maxChamferDegrees
- each line segment (except first and last) touches the arc at its midpoint.
- If the turn is larger than
constructCurveXYOffset(curves: Path | Loop, offsetDistanceOrOptions: number | OffsetOptions | JointOptions): undefined | CurveCollection
Parameter | Type | Description |
---|---|---|
curves | Path | Loop | base curves. |
offsetDistanceOrOptions | number | OffsetOptions | JointOptions | offset distance (positive to left of curve, negative to right) or options object. |
Returns - undefined | CurveCollection
Defined in
- curve/RegionOps.ts Line 360
Last Updated: 30 November, 2023