collectChains MethodStatic
- Restructure curve fragments as chains and offsets
- BEWARE that if the input is not a loop the classification of outputs is suspect.
collectChains(fragments: GeometryQuery[], gapTolerance: number, planarTolerance: number = Geometry.smallMetricDistance): ChainTypes
Parameter | Type | Description |
---|---|---|
fragments | GeometryQuery[] | fragments to be chained |
gapTolerance | number | distance to be treated as "effectively zero" when joining head-to-tail. |
planarTolerance | number |
Returns - ChainTypes
Defined in
Last Updated: 30 November, 2023