createMiteredPipeSections MethodStatic
- Create section arcs for mitered pipe.
- At each end of each pipe, the pipe is cut by the plane that bisects the angle between successive pipe centerlines.
- The arc definitions are constructed so that lines between corresponding fractional positions on the arcs are axial lines on the pipes.
- This means that each arc definition axes (aka vector0 and vector90) are not perpendicular to each other.
- Circular or elliptical pipe cross sections can be specified by supplying either a radius, a pair of semi-axis lengths, or a full Arc3d.
- For semi-axis length input, x corresponds to an ellipse local axis nominally situated parallel to the xy-plane.
- The center of Arc3d input is translated to the centerline start point to act as initial cross section.
createMiteredPipeSections(centerline: IndexedXYZCollection, sectionData: number | Arc3d | Readonly<WritableXAndY>): Arc3d[]
Parameter | Type | Description |
---|---|---|
centerline | IndexedXYZCollection | centerline of pipe |
sectionData | number | Arc3d | Readonly<WritableXAndY> | circle radius, ellipse semi-axis lengths, or full Arc3d |
Returns - Arc3d[]
Defined in
- curve/CurveFactory.ts Line 303
Last Updated: 30 November, 2023