createLineSpiralSpiralLineWithSpiralLength MethodStatic
Compute 2 spirals (all in XY) for a symmetric line-to-line transition.
- Spiral length is given.
- tangency points float on both lines.
createLineSpiralSpiralLineWithSpiralLength(spiralType: IntegratedSpiralTypeName, pointA: Point3d, pointB: Point3d, pointC: Point3d, spiralLength: number): undefined | GeometryQuery[]
Parameter | Type | Description |
---|---|---|
spiralType | IntegratedSpiralTypeName | name of spiral type. THIS MUST BE AN "Integrated" SPIRAL TYPE |
pointA | Point3d | inbound start point. |
pointB | Point3d | |
pointC | Point3d | |
spiralLength | number | for each part of the spiral pair. |
Returns - undefined | GeometryQuery[]
array with the computed spirals, or undefined if failure.
Defined in
- curve/CurveFactory.ts Line 439
Last Updated: 30 November, 2023