appendToArcInPlace MethodStatic
If arcB
is a continuation of arcA
, extend arcA
(in place) to include the range of arcB
- This only succeeds if the two arcs are part of identical complete arcs and end of
arcA
matches the beginning ofarcB
. - "Reversed"
appendToArcInPlace(arcA: Arc3d, arcB: Arc3d, allowReverse: boolean = false): boolean
Parameter | Type | Description |
---|---|---|
arcA | Arc3d | |
arcB | Arc3d | |
allowReverse | boolean |
Returns - boolean
Defined in
- curve/CurveFactory.ts Line 209
Last Updated: 30 November, 2023