resolveRadiansToSweepFraction MethodStatic
Adjust a radians value to an angle sweep, allowing the extendParam to affect choice among periodic fractions.
- if radians is within the sweep, convert it to a fraction of the sweep.
- if radians is outside, use the extendParam to choose among:
- fraction below 0
- fraction above 1
resolveRadiansToSweepFraction(extendParam: VariantCurveExtendParameter, radians: number, sweep: AngleSweep): number
Parameter | Type | Description |
---|---|---|
extendParam | VariantCurveExtendParameter | |
radians | number | |
sweep | AngleSweep |
Returns - number
Defined in
- curve/CurveExtendMode.ts Line 69
Last Updated: 30 November, 2023