correctFraction MethodStatic
- if fraction is between 0 and 1 return it unchanged.
- if fraction is less than 0 use the variant param to choose the fraction or 0
- if fraction is greater than 1 use the variant param to choose the fraction or 1
correctFraction(extendParam: VariantCurveExtendParameter, fraction: number): number
Parameter | Type | Description |
---|---|---|
extendParam | VariantCurveExtendParameter | |
fraction | number |
Returns - number
Defined in
- curve/CurveExtendMode.ts Line 50
Last Updated: 30 November, 2023