unitPerpendicularXY Method
Return a vector which is in the xy plane, perpendicular to the xy part of this vector, and of unit length.
- If the xy part is 00, the return is the rotated (but not normalized) xy parts of this vector.
unitPerpendicularXY(result?: Vector3d): Vector3d
Parameter | Type | Description |
---|---|---|
result | Vector3d | optional preallocated result. |
Returns - Vector3d
Defined in
- geometry3d/Point3dVector3d.ts Line 993
Last Updated: 30 November, 2023