rotate90Around Method
Rotate this vector 90 degrees around an axis vector.
- Note that simple cross is in the plane perpendicular to axis -- it loses the part of "this" that is along the axis. The unit and scale is supposed to fix that. This matches with Rodrigues' rotation formula because cos(theta) = 0 and sin(theta) = 1
rotate90Around(axis: Vector3d, result?: Vector3d): undefined | Vector3d
Parameter | Type | Description |
---|---|---|
axis | Vector3d | |
result | Vector3d |
Returns - undefined | Vector3d
the (new or optionally reused result) rotated vector, or undefined if the axis vector cannot be normalized.
Defined in
- geometry3d/Point3dVector3d.ts Line 1045
Last Updated: 30 November, 2023