planarRadiansTo Method
Return the angle in radians (not as strongly-typed Angle) from this vector to vectorB, measured between their projections to the plane with the given normal.
- The returned angle is between
-Math.PI
andMath.PI
.
planarRadiansTo(vectorB: Vector3d, planeNormal: Vector3d): number
Parameter | Type | Description |
---|---|---|
vectorB | Vector3d | target vector |
planeNormal | Vector3d | the normal vector to the plane. |
Returns - number
Defined in
- geometry3d/Point3dVector3d.ts Line 1446
Last Updated: 30 November, 2023