planarAngleTo Method
Return the (strongly-type) angle from this vector to vectorB, measured between their projections to the plane with the given normal.
- The returned angle is between -180 and 180 degrees.
planarAngleTo(vectorB: Vector3d, planeNormal: Vector3d): Angle
Parameter | Type | Description |
---|---|---|
vectorB | Vector3d | target vector. |
planeNormal | Vector3d | the normal vector to the plane. |
Returns - Angle
Defined in
- geometry3d/Point3dVector3d.ts Line 1466
Last Updated: 30 November, 2023