dotProductStartEndXYZW Method
Dot product with vector from pointA to pointB, with pointB given as (weighted) wx,wy,wz,w
- We need to unweight pointB (which is a homogeneous point) to be able to participate in the vector dot product
- if the weight is near zero metric, the return is zero.
dotProductStartEndXYZW(pointA: Point3d, wx: number, wy: number, wz: number, w: number): number
Parameter | Type | Description |
---|---|---|
pointA | Point3d | |
wx | number | |
wy | number | |
wz | number | |
w | number |
Returns - number
Defined in
- geometry3d/Point3dVector3d.ts Line 1318
Last Updated: 30 November, 2023