setFromJSON Method
Set this Transform instance from flexible inputs:
- Any object (such as another Transform) that has
origin
andmatrix
members accepted by Point3d.setFromJSON and Matrix3d.setFromJSON - An array of 3 number arrays, each with 4 entries which are rows in a 3x4 matrix.
- An array of 12 numbers, each block of 4 entries as a row 3x4 matrix.
setFromJSON(json?: Transform | TransformProps): void
Parameter | Type | Description |
---|---|---|
json | Transform | TransformProps |
Returns - void
Defined in
- geometry3d/Transform.ts Line 66
Last Updated: 30 November, 2023