multiplyTransformTransform Method

multiply this Transform times other Transform.

‘this‘ transform with matrix part A and translation a[Aa01]‘other‘ transform with matrix part B and translation part b promoted to block transform[Bb01]product[Aa01][Bb01]=[ABAb+a01]\begin{matrix}
   \text{`this` transform with matrix part }\bold{A}\text{ and translation }\bold{a} & \blockTransform{A}{a}\\
   \text{`other` transform with matrix part }\bold{B}\text{ and translation part }\bold{b}\text{ promoted to block transform} & \blockTransform{B}{b} \\
\text{product}& \blockTransform{A}{a}\blockTransform{B}{b}=\blockTransform{AB}{Ab + a}
\end{matrix}

multiplyTransformTransform(other: Transform, result?: Transform): Transform

Parameter Type Description
other Transform right hand transform for multiplication.
result Transform optional preallocated result to reuse.

Returns - Transform

Defined in

Last Updated: 30 November, 2023