multiplyTransformMatrix3d Method

multiply this Transform times other Matrix3d, with other considered to be a Transform with 0 translation.

‘this‘ transform with matrix part A and translation b[Bb01]‘other‘ matrix B promoted to block transform[B001]product[Aa01][B001]=[ABa01]\begin{matrix}
   \text{`this` transform with matrix part }\bold{A}\text{ and translation }\bold{b} & \blockTransform{B}{b}\\
   \text{`other` matrix }\bold{B}\text{ promoted to block transform} & \blockTransform{B}{0} \\
\text{product}& \blockTransform{A}{a}\blockTransform{B}{0}=\blockTransform{AB}{a}
\end{matrix}

multiplyTransformMatrix3d(other: Matrix3d, result?: Transform): Transform

Parameter Type Description
other Matrix3d right hand Matrix3d for multiplication.
result Transform optional preallocated result to reuse.

Returns - Transform

Defined in

Last Updated: 30 November, 2023