multiplyRange Method
Return the range of the transformed corners.
- The 8 corners are transformed individually.
- Note that if there is anything other than translation and principal axis scaling in the transform, the volume of the range rotation will increase.
- Hence to get a "tight" range on rotated geometry, a range computation must be made on the rotated geometry itself.
multiplyRange(range: Range3d, result?: Range3d): Range3d
Parameter | Type | Description |
---|---|---|
range | Range3d | |
result | Range3d |
Returns - Range3d
Defined in
- geometry3d/Transform.ts Line 606
Last Updated: 30 November, 2023