matchArrayLengths MethodStatic
- If destination has more values than source, remove the extras.
- If destination has fewer values, use the constructionFunction to create new ones.
matchArrayLengths(source: any[], dest: any[], constructionFunction: () => any): number
Parameter | Type | Description |
---|---|---|
source | any[] | array |
dest | any[] | destination array, to be modified to match source length |
constructionFunction | () => any | function to call to create new entries. |
Returns - number
Defined in
- geometry3d/Transform.ts Line 469
Last Updated: 30 November, 2023