initFromRange MethodStatic
Initialize transforms that map each direction of a box (axis aligned) to [0,1]
.
- The corner coordinates do not need to be in order in any of the x,y,z directions.
- The npcToGlobalTransform (if supplied) maps 000 to the point named point000.
- The npcToGlobalTransform (if supplied) maps 11 to the point named point000.
- The globalToNpc transform is the inverse.
initFromRange(min: Point3d, max: Point3d, npcToGlobal?: Transform, globalToNpc?: Transform): void
Parameter | Type | Description |
---|---|---|
min | Point3d | the "000" corner of the box |
max | Point3d | the "111" corner of the box |
npcToGlobal | Transform | (object created by caller, re-initialized here) transform that carries 01 coordinates into the min,max box. |
globalToNpc | Transform | (object created by caller, re-initialized here) transform that carries world coordinates into 01 |
Returns - void
Defined in
- geometry3d/Transform.ts Line 651
Last Updated: 30 November, 2023