createOriginAndMatrix MethodStatic
Create by directly installing origin and matrix this is a the appropriate construction when the columns of the matrix are coordinate axes of a local-to-global mapping Note there is a closely related createFixedPointAndMatrix whose point input is the fixed point of the global-to-global transformation.
createOriginAndMatrix(origin: undefined | XYZ, matrix: undefined | Matrix3d, result?: Transform): Transform
Parameter | Type | Description |
---|---|---|
origin | undefined | XYZ | |
matrix | undefined | Matrix3d | |
result | Transform |
Returns - Transform
Defined in
- geometry3d/Transform.ts Line 231
Last Updated: 30 November, 2023