unitNormal MethodStatic
Return a unit normal to the plane of the polygon.
unitNormal(points: IndexedXYZCollection, result: Vector3d): boolean
Parameter | Type | Description |
---|---|---|
points | IndexedXYZCollection | array of points around the polygon. |
result | Vector3d | caller-allocated result vector. |
Returns - boolean
true if and only if result has unit length
Defined in
- geometry3d/PolygonOps.ts Line 567
Last Updated: 30 November, 2023