sortOuterAndHoleLoopsXY MethodStatic
Reverse loops as necessary to make them all have CCW orientation for given outward normal.
- Return an array of arrays which capture the input pointers.
- In each first level array:
- The first loop is an outer loop.
- all subsequent loops are holes
- The outer loop is CCW
- The holes are CW.
- Call RegionOps.sortOuterAndHoleLoopsXY to have the result returned as a UnionRegion
sortOuterAndHoleLoopsXY(loops: IndexedReadWriteXYZCollection[]): IndexedReadWriteXYZCollection[][]
Parameter | Type | Description |
---|---|---|
loops | IndexedReadWriteXYZCollection[] | multiple loops to sort and reverse. |
Returns - IndexedReadWriteXYZCollection[][]
Defined in
- geometry3d/PolygonOps.ts Line 823
Last Updated: 30 November, 2023