classifyPointInPolygonXY MethodStatic
Test if point (x,y) is IN, OUT or ON a polygon.
classifyPointInPolygonXY(x: number, y: number, points: IndexedXYZCollection): undefined | number
Parameter | Type | Description |
---|---|---|
x | number | x coordinate |
y | number | y coordinate |
points | IndexedXYZCollection | array of xy coordinates. |
Returns - undefined | number
(1) for in, (-1) for OUT, (0) for ON
Defined in
- geometry3d/PolygonOps.ts Line 758
Last Updated: 30 November, 2023