centroidAreaNormal MethodStatic
Return a Ray3d with (assuming the polygon is planar and not self-intersecting)
- origin at the centroid of the (3D) polygon
- normal is a unit vector perpendicular to the plane
- 'a' member is the area.
centroidAreaNormal(points: Point3d[] | IndexedXYZCollection): undefined | Ray3d
Parameter | Type | Description |
---|---|---|
points | Point3d[] | IndexedXYZCollection |
Returns - undefined | Ray3d
Defined in
- geometry3d/PolygonOps.ts Line 476
Last Updated: 30 November, 2023