addSecondMomentVolumeProducts MethodStatic
Accumulate to the matrix of volume products of a polygon with respect to an origin.
- The polygon is assumed to be planar and non-self-intersecting.
- Accumulated values are integrals over tetrahedra from the origin to triangles on the polygon.
addSecondMomentVolumeProducts(points: IndexedXYZCollection, origin: Point3d, moments: Matrix4d): void
Parameter | Type | Description |
---|---|---|
points | IndexedXYZCollection | array of points around the polygon. Final closure point is not needed. |
origin | Point3d | origin for tetrahedra |
moments | Matrix4d | 4x4 matrix where products are accumulated. |
Returns - void
Defined in
- geometry3d/PolygonOps.ts Line 609
Last Updated: 30 November, 2023