unpackFloat64ArrayToPointsAndWeights MethodStatic
unpack from xyzw xyzw... array to array of Point3d and array of weight.
unpackFloat64ArrayToPointsAndWeights(data: Float64Array, points: Point3d[], weights: number[], pointFormatter: (x: number, y: number, z: number) => any = Point3d.create): void
Parameter | Type | Description |
---|---|---|
data | Float64Array | |
points | Point3d[] | |
weights | number[] | |
pointFormatter | (x: number, y: number, z: number) => any |
Returns - void
Defined in
- geometry3d/PointHelpers.ts Line 361
Last Updated: 30 November, 2023