convexPolygonSplitInsideOutsidePlane MethodStatic
Split a (convex) polygon into 2 parts.
convexPolygonSplitInsideOutsidePlane(plane: PlaneAltitudeEvaluator, xyz: Point3d[], xyzIn: Point3d[], xyzOut: Point3d[], altitudeRange: Range1d): void
Parameter | Type | Description |
---|---|---|
plane | PlaneAltitudeEvaluator | |
xyz | Point3d[] | original polygon |
xyzIn | Point3d[] | array to receive inside part |
xyzOut | Point3d[] | array to receive outside part |
altitudeRange | Range1d | min and max altitudes encountered. |
Returns - void
Defined in
- geometry3d/PolygonOps.ts Line 1462
Last Updated: 30 November, 2023