convexPolygonClipInPlace MethodStatic
Clip a polygon, returning the clip result in the same object.
convexPolygonClipInPlace(plane: PlaneAltitudeEvaluator, xyz: Point3d[], work: undefined | Point3d[], tolerance: number = Geometry.smallMetricDistance): void
Parameter | Type | Description |
---|---|---|
plane | PlaneAltitudeEvaluator | |
xyz | Point3d[] | input/output polygon |
work | undefined | Point3d[] | scratch object |
tolerance | number | tolerance for on-plane decision. |
Returns - void
Defined in
- geometry3d/PolygonOps.ts Line 1501
Last Updated: 30 November, 2023