countNonDuplicates MethodStatic
Count the number of points, but ...
- ignore trailing duplicates of point 0.
- return 0 if there are any duplicates within the remaining points.
countNonDuplicates(points: Point3d[], tolerance: number = Geometry.smallMetricDistance): number
Parameter | Type | Description |
---|---|---|
points | Point3d[] | points to examine. |
tolerance | number |
Returns - number
Defined in
- geometry3d/PointHelpers.ts Line 765
Last Updated: 30 November, 2023