computeConvexHullXY MethodStatic
Computes the hull of the XY projection of points.
- Returns the hull as an array of Point3d
- Optionally returns non-hull points in
insidePoints[]
- If both arrays empty if less than 3 points.
computeConvexHullXY(points: Point3d[], hullPoints: Point3d[], insidePoints: Point3d[], addClosurePoint: boolean = false): void
Parameter | Type | Description |
---|---|---|
points | Point3d[] | |
hullPoints | Point3d[] | |
insidePoints | Point3d[] | |
addClosurePoint | boolean |
Returns - void
Defined in
- geometry3d/PointHelpers.ts Line 918
Last Updated: 30 November, 2023