createFromPackedXYZW MethodStatic
Copy and unweight xyzw.
createFromPackedXYZW(xyzData: Float64Array, pointIndex: number, result?: Point3d): undefined | Point3d
Parameter | Type | Description |
---|---|---|
xyzData | Float64Array | flat array of x,y,z,w,x,y,z,w for multiple points |
pointIndex | number | index of point to extract. This index is multiplied by 4 to obtain starting index in the array. |
result | Point3d | optional result point. |
Returns - undefined | Point3d
Defined in
- geometry3d/Point3dVector3d.ts Line 470
Last Updated: 30 November, 2023