splitConvexPolygonInsideOutsidePlane MethodStatic
Split a (convex) polygon into 2 parts based on altitude evaluations.
- POSITIVE ALTITUDE IS IN
splitConvexPolygonInsideOutsidePlane(plane: PlaneAltitudeEvaluator, xyz: IndexedReadWriteXYZCollection, xyzPositive: IndexedReadWriteXYZCollection, xyzNegative: IndexedReadWriteXYZCollection, altitudeRange: Range1d): void
Parameter | Type | Description |
---|---|---|
plane | PlaneAltitudeEvaluator | any PlaneAltitudeEvaluator object that can evaluate plane.altitude(xyz) for distance from the plane. |
xyz | IndexedReadWriteXYZCollection | original polygon |
xyzPositive | IndexedReadWriteXYZCollection | array to receive inside part (altitude > 0) |
xyzNegative | IndexedReadWriteXYZCollection | array to receive outside part |
altitudeRange | Range1d | min and max altitudes encountered. |
Returns - void
Defined in
- geometry3d/PolygonOps.ts Line 1219
Last Updated: 30 November, 2023