createGeodesicPath MethodStatic

createGeodesicPath(originalEllipsoid: Ellipsoid, startAngles: LongitudeLatitudeNumber, endAngles: LongitudeLatitudeNumber, density: number | Angle): undefined | GeodesicPathPoint[]

Parameter Type Description
originalEllipsoid Ellipsoid Given start and endpoints on an ellipsoid, compute points along a near-optimal shortest path.
* The points are located so that at each point the local surface normal is contained in the plane of the point and its two neighbors.
startAngles LongitudeLatitudeNumber angles for the start of the path
endAngles LongitudeLatitudeNumber angles for the end of the path
density number | Angle If this is a number, it is the requested edge count. If this is an angle, it ias an angular spacing measured in the great arc through the two points.

Returns - undefined | GeodesicPathPoint[]

Defined in

Last Updated: 30 November, 2023