approximateMinimumLengthSectionArc MethodStatic
Construct various section arcs (on the ellipsoid), using planes that (a) pass through the two given points and (b) have in-plane vector sampled between the normals of the two points.
- Each candidate ellipse has is in a plane with ellipsoid normal at vector constructed "between" the endpoint normals.
- The intermediate construction is by interpolation between stated fractions (which maybe outside 0 to 1)
approximateMinimumLengthSectionArc(ellipsoid: Ellipsoid, angleA: LongitudeLatitudeNumber, angleB: LongitudeLatitudeNumber, numSample: number, normalInterpolationFraction0: number, normalInterpolationFraction1: number): undefined | { minLengthArc: Arc3d, minLengthNormalInterpolationFraction: number }
Parameter | Type | Description |
---|---|---|
ellipsoid | Ellipsoid | |
angleA | LongitudeLatitudeNumber | start point of all candidates |
angleB | LongitudeLatitudeNumber | end point of all candidates |
numSample | number | number of ellipses to construct as candidates. |
normalInterpolationFraction0 | number | |
normalInterpolationFraction1 | number |
Returns - undefined | { minLengthArc: Arc3d, minLengthNormalInterpolationFraction: number }
Defined in
- geometry3d/Ellipsoid.ts Line 1158
Last Updated: 30 November, 2023