createRightHandedFrame MethodStatic
create a localToWorld frame for the given data.
- origin is at first point
- x axis in direction of first nonzero vector present or implied by the input.
- y axis is perpendicular to x and contains (in positive side) the next vector present or implied by the input.
createRightHandedFrame(defaultUpVector: undefined | Vector3d, ...params: any[]): undefined | Transform
Parameter | Type | Description |
---|---|---|
defaultUpVector | undefined | Vector3d | |
...params | any[] |
Returns - undefined | Transform
Defined in
- geometry3d/FrameBuilder.ts Line 220
Last Updated: 30 November, 2023