createLocalToWorldTransformInRange MethodStatic
Create the localToWorld transform from a range to axes of its parent coordinate system.
createLocalToWorldTransformInRange(range: Range3d, scaleSelect: AxisScaleSelect = AxisScaleSelect.NonUniformRangeContainment, fractionX: number = 0, fractionY: number = 0, fractionZ: number = 0, defaultAxisLength: number = 1.0): Transform
Parameter | Type | Description |
---|---|---|
range | Range3d | range to inspect |
scaleSelect | AxisScaleSelect | selects size of localToWorld axes. |
fractionX | number | fractional coordinate of frame origin x |
fractionY | number | fractional coordinate of frame origin y |
fractionZ | number | fractional coordinate of frame origin z |
defaultAxisLength | number | if true and any axis length is 0, that axis vector takes this physical length. |
Returns - Transform
Defined in
- geometry3d/FrameBuilder.ts Line 313
Last Updated: 30 November, 2023