rangeOfClipperIntersectionWithRange MethodStatic
Return the range of various types of clippers
ConvexClipPlaneSet
-- dispatch torangeOfConvexClipPlaneSetIntersectionWithRange
UnionOfConvexClipPlaneSet
-- union of ranges of memberConvexClipPlaneSet
ClipPrimitive
-- access itsUnionOfConvexClipPlaneSet
.ClipVector
-- intersection of the ranges of itsClipPrimitive
.undefined
-- entire input range.- If
observeInvisibleFlag
is false, the "invisible" properties are ignored, and this effectively returns the range of the edge work of the members - If
observeInvisibleFlag
is true, the "invisible" properties are observed, and "invisible" parts do not restrict the range.
rangeOfClipperIntersectionWithRange(clipper: undefined | ConvexClipPlaneSet | ClipPrimitive | UnionOfConvexClipPlaneSets | ClipVector, range: Range3d, observeInvisibleFlag: boolean = true): Range3d
Parameter | Type | Description |
---|---|---|
clipper | undefined | ConvexClipPlaneSet | ClipPrimitive | UnionOfConvexClipPlaneSets | ClipVector | |
range | Range3d | non-null range. |
observeInvisibleFlag | boolean | indicates how "invisible" bit is applied for ClipPrimitive. |
Returns - Range3d
Defined in
- clipping/ClipUtils.ts Line 370
Last Updated: 30 November, 2023