loopsOfConvexClipPlaneIntersectionWithRange MethodStatic
Return a (possibly empty) array of geometry (Loops !!) which are facets of the intersection of the convex set intersecting a range.
- return zero length array for (a) null range or (b) no intersections
loopsOfConvexClipPlaneIntersectionWithRange(allClippers: ConvexClipPlaneSet | ClipPlane | UnionOfConvexClipPlaneSets, range: Range3d, includeConvexSetFaces: boolean = true, includeRangeFaces: boolean = true, ignoreInvisiblePlanes: boolean = false): GeometryQuery[]
Parameter | Type | Description |
---|---|---|
allClippers | ConvexClipPlaneSet | ClipPlane | UnionOfConvexClipPlaneSets | convex or union clipper |
range | Range3d | range to intersect |
includeConvexSetFaces | boolean | if false, do not compute facets originating as convex set planes. |
includeRangeFaces | boolean | if false, do not compute facets originating as range faces |
ignoreInvisiblePlanes | boolean | if true, do NOT compute a facet for convex set faces marked invisible. |
Returns - GeometryQuery[]
Defined in
- clipping/ClipUtils.ts Line 322
Last Updated: 30 November, 2023