doPolygonClipSequence MethodStatic
Pass polygon xyz
through a sequence of PolygonClip steps.
- At the outset,
xyz
is the (only) entry in a set of candidates. - For each clipper, each candidate is presented for appendPolygon to inside and outside parts.
- Each (in,out) result is distributed among (acceptedIn, acceptedOut, candidates) according to (inAction, outAction)
- At the end, all remaining candidates are distributed among (acceptedIn, acceptedOut, finalUnknown) according to finalAction
- Any clipper that does not have an appendPolygonClip method is skipped.
doPolygonClipSequence(xyz: GrowableXYZArray, clippers: Clipper[], acceptedIn: undefined | GrowableXYZArray[], acceptedOut: undefined | GrowableXYZArray[], finalCandidates: undefined | GrowableXYZArray[], inAction: ClipStepAction, outAction: ClipStepAction, finalFragmentAction: ClipStepAction, arrayCache: undefined | ): void
Parameter | Type | Description |
---|---|---|
xyz | GrowableXYZArray | |
clippers | Clipper[] | |
acceptedIn | undefined | GrowableXYZArray[] | |
acceptedOut | undefined | GrowableXYZArray[] | |
finalCandidates | undefined | GrowableXYZArray[] | |
inAction | ClipStepAction | |
outAction | ClipStepAction | |
finalFragmentAction | ClipStepAction | |
arrayCache | undefined | |
Returns - void
Defined in
- clipping/ClipUtils.ts Line 735
Last Updated: 30 November, 2023