doesConvexClipPlaneSetIntersectRange MethodStatic
Emit point loops for intersection of a convex set with a range.
- return zero length array for (a) null range or (b) no intersections
doesConvexClipPlaneSetIntersectRange(convexSet: ConvexClipPlaneSet, range: Range3d, includeConvexSetFaces: boolean = true, includeRangeFaces: boolean = true, ignoreInvisiblePlanes: boolean = false): boolean
Parameter | Type | Description |
---|---|---|
convexSet | ConvexClipPlaneSet | |
range | Range3d | range to intersect |
includeConvexSetFaces | boolean | if false, do not compute facets originating as convex set planes. |
includeRangeFaces | boolean | if false, do not compute facets originating as range faces |
ignoreInvisiblePlanes | boolean | if true, do NOT compute a facet for convex set faces marked invisible. |
Returns - boolean
Defined in
- clipping/ClipUtils.ts Line 461
Last Updated: 30 November, 2023