doesClipperIntersectRange MethodStatic
Test if various types of clippers have any intersection with a range.
- This follows the same logic as
rangeOfClipperIntersectionWithRange
but attempts to exit at earliest point of confirmed intersection ConvexClipPlaneSet
-- dispatch todoesConvexClipPlaneSetIntersectRange
UnionOfConvexClipPlaneSet
-- union of ranges of memberConvexClipPlaneSet
ClipPrimitive
-- access itsUnionOfConvexClipPlaneSet
.ClipVector
-- intersection of the ranges of itsClipPrimitive
.undefined
-- entire input range.- If
observeInvisibleFlag
is false, the "invisible" properties are ignored, and holes do not affect the result. - If
observeInvisibleFlag
is true, the "invisible" properties are observed, and may affect the result.
doesClipperIntersectRange(clipper: undefined | ConvexClipPlaneSet | ClipPrimitive | UnionOfConvexClipPlaneSets | ClipVector, range: Range3d, observeInvisibleFlag: boolean = true): boolean
Parameter | Type | Description |
---|---|---|
clipper | undefined | ConvexClipPlaneSet | ClipPrimitive | UnionOfConvexClipPlaneSets | ClipVector | |
range | Range3d | non-null range. |
observeInvisibleFlag | boolean | indicates how "invisible" bit is applied for ClipPrimitive. |
Returns - boolean
Defined in
- clipping/ClipUtils.ts Line 417
Last Updated: 30 November, 2023