clipSegmentBelowPlaneXY MethodStatic
Find the portion of a line within a half-plane clip.
- The half-plane clip is to the left of the line from clipA to clipB.
- The original clipped segment has fractions 0 and 1 at respective segment points.
- Caller initializes the interval
- This method reduces the interval size.
- See clipSegmentToCCWTriangleXY for typical use.
clipSegmentBelowPlaneXY(plane: Plane3dByOriginAndUnitNormal, segmentPoint0: Readonly<WritableXAndY>, segmentPoint1: Readonly<WritableXAndY>, interval: Range1d, absoluteTolerance: number = 1.0e-14): void
Parameter | Type | Description |
---|---|---|
plane | Plane3dByOriginAndUnitNormal | |
segmentPoint0 | Readonly<WritableXAndY> | First point of clipped segment |
segmentPoint1 | Readonly<WritableXAndY> | Second point of clipped segment |
interval | Range1d | Live interval. |
absoluteTolerance | number | absolute tolerance for both cross product values to indicate "on" the line |
Returns - void
Defined in
- clipping/ClipUtils.ts Line 641
Last Updated: 30 November, 2023