announceLoopsOfConvexClipPlaneSetIntersectRange MethodStatic
Emit point loops for intersection of a convex set with a range.
- return zero length array for (a) null range or (b) no intersections
announceLoopsOfConvexClipPlaneSetIntersectRange(convexSet: ConvexClipPlaneSet | ClipPlane, range: Range3d, loopFunction: (loopPoints: GrowableXYZArray) => void, includeConvexSetFaces: boolean = true, includeRangeFaces: boolean = true, ignoreInvisiblePlanes: boolean = false): void
Parameter | Type | Description |
---|---|---|
convexSet | ConvexClipPlaneSet | ClipPlane | |
range | Range3d | range to intersect |
loopFunction | (loopPoints: GrowableXYZArray) => void | |
includeConvexSetFaces | boolean | if false, do not compute facets originating as convex set planes. |
includeRangeFaces | boolean | if false, do not compute facets originating as range faces |
ignoreInvisiblePlanes | boolean | if true, do NOT compute a facet for convex set faces marked invisible. |
Returns - void
Defined in
- clipping/ClipUtils.ts Line 265
Last Updated: 30 November, 2023