snapLocationToEdge Method
Adjust the location to an edge of the triangle if within either given tolerance.
snapLocationToEdge(location: TriangleLocationDetail, distanceTolerance: number = Geometry.smallMetricDistance, parameterTolerance: number = Geometry.smallFraction): boolean
Parameter | Type | Description |
---|---|---|
location | TriangleLocationDetail | details of a point in the plane of the triangle, location.local and location.world possibly updated to lie on a triangle edge |
distanceTolerance | number | absolute distance tolerance (or zero to ignore) |
parameterTolerance | number | barycentric coordinate fractional tolerance (or zero to ignore) |
Returns - boolean
whether the location was adjusted
Defined in
- geometry3d/BarycentricTriangle.ts Line 443
Last Updated: 30 November, 2023