isInsideTriangle MethodStatic
Examine a point's barycentric coordinates to determine if it lies inside the triangle but not on an edge/vertex.
- No parametric tolerance is used.
- It is assumed b0 + b1 + b2 = 1.
isInsideTriangle(b0: number, b1: number, b2: number): boolean
Parameter | Type | Description |
---|---|---|
b0 | number | |
b1 | number | |
b2 | number |
Returns - boolean
whether the point with barycentric coordinates is strictly inside the triangle.
Defined in
- geometry3d/BarycentricTriangle.ts Line 226
Last Updated: 30 November, 2023